forked from rmandrad/openwrt
-
Notifications
You must be signed in to change notification settings - Fork 1
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Merge branch 'bananapi4' of github.com:rmandrad/openwrt into bananapi…
…4-nvme-wip
- Loading branch information
Showing
64 changed files
with
2,474 additions
and
516 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
|
@@ -7,10 +7,13 @@ | |
|
||
include $(TOPDIR)/rules.mk | ||
|
||
PKG_VERSION:=2.10 | ||
PKG_VERSION:=2.12 | ||
PKG_RELEASE:=1 | ||
|
||
PKG_HASH:=88215a62291b9ba87da8e50b077741103cdc08fb6c9e1ebd34dfaace746d3201 | ||
PKG_SOURCE_PROTO:=git | ||
PKG_SOURCE_URL:=https://github.com/ARM-software/arm-trusted-firmware.git | ||
PKG_SOURCE_VERSION:=v$(PKG_VERSION) | ||
PKG_MIRROR_HASH:=51b2022baa25df7fd8f2e6d2709c9351c14b17447cda64759a8a1d432f9d1c11 | ||
PKG_MAINTAINER:=Thomas Richard <[email protected]> | ||
|
||
include $(INCLUDE_DIR)/kernel.mk | ||
|
66 changes: 66 additions & 0 deletions
66
...ed-firmware-stm32/patches/0001-Revert-feat-stm32mp1-fdts-remove-RTC-clock-configura.patch
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,66 @@ | ||
From 0e1a71d84585ec33b479c2cb8c8d65a4f6734dbe Mon Sep 17 00:00:00 2001 | ||
From: Thomas Richard <[email protected]> | ||
Date: Wed, 4 Dec 2024 14:26:52 +0100 | ||
Subject: [PATCH] Revert "feat(stm32mp1-fdts): remove RTC clock configuration" | ||
|
||
This reverts commit 703a581e2522bffe21b421c98994dc02aed2934c. | ||
--- | ||
fdts/stm32mp135f-dk.dts | 2 ++ | ||
fdts/stm32mp157c-ed1.dts | 2 ++ | ||
fdts/stm32mp15xx-dkx.dtsi | 2 ++ | ||
3 files changed, 6 insertions(+) | ||
|
||
--- a/fdts/stm32mp135f-dk.dts | ||
+++ b/fdts/stm32mp135f-dk.dts | ||
@@ -190,6 +190,7 @@ | ||
CLK_AXI_PLL2P | ||
CLK_MLAHBS_PLL3 | ||
CLK_CKPER_HSE | ||
+ CLK_RTC_LSE | ||
CLK_SDMMC1_PLL4P | ||
CLK_SDMMC2_PLL4P | ||
CLK_STGEN_HSE | ||
@@ -211,6 +212,7 @@ | ||
DIV(DIV_APB4, 1) | ||
DIV(DIV_APB5, 2) | ||
DIV(DIV_APB6, 1) | ||
+ DIV(DIV_RTC, 0) | ||
>; | ||
|
||
st,pll_vco { | ||
--- a/fdts/stm32mp157c-ed1.dts | ||
+++ b/fdts/stm32mp157c-ed1.dts | ||
@@ -194,6 +194,7 @@ | ||
CLK_MPU_PLL1P | ||
CLK_AXI_PLL2P | ||
CLK_MCU_PLL3P | ||
+ CLK_RTC_LSE | ||
CLK_MCO1_DISABLED | ||
CLK_MCO2_DISABLED | ||
CLK_CKPER_HSE | ||
@@ -242,6 +243,7 @@ | ||
DIV(DIV_APB3, 1) | ||
DIV(DIV_APB4, 1) | ||
DIV(DIV_APB5, 2) | ||
+ DIV(DIV_RTC, 23) | ||
DIV(DIV_MCO1, 0) | ||
DIV(DIV_MCO2, 0) | ||
>; | ||
--- a/fdts/stm32mp15xx-dkx.dtsi | ||
+++ b/fdts/stm32mp15xx-dkx.dtsi | ||
@@ -198,6 +198,7 @@ | ||
CLK_MPU_PLL1P | ||
CLK_AXI_PLL2P | ||
CLK_MCU_PLL3P | ||
+ CLK_RTC_LSE | ||
CLK_MCO1_DISABLED | ||
CLK_MCO2_DISABLED | ||
CLK_CKPER_HSE | ||
@@ -246,6 +247,7 @@ | ||
DIV(DIV_APB3, 1) | ||
DIV(DIV_APB4, 1) | ||
DIV(DIV_APB5, 2) | ||
+ DIV(DIV_RTC, 23) | ||
DIV(DIV_MCO1, 0) | ||
DIV(DIV_MCO2, 0) | ||
>; |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
|
@@ -7,10 +7,10 @@ | |
|
||
include $(TOPDIR)/rules.mk | ||
|
||
PKG_VERSION:=4.3.0 | ||
PKG_VERSION:=4.4.0 | ||
PKG_RELEASE:=1 | ||
|
||
PKG_HASH:=390b271905c828d6def9fa6a77bbaa425f3b434d733c8eb18f582ccbc6896096 | ||
PKG_HASH:=b13c65ff2abcd21a9200cb0131f34d61bde7c31eb0427fa761d27c3b87c7fec8 | ||
PKG_MAINTAINER:=Thomas Richard <[email protected]> | ||
|
||
OPTEE_USE_INTREE_DTC:=1 | ||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
|
@@ -7,10 +7,10 @@ | |
|
||
include $(TOPDIR)/rules.mk | ||
|
||
PKG_VERSION:=2024.07 | ||
PKG_VERSION:=2024.10 | ||
PKG_RELEASE:=1 | ||
|
||
PKG_HASH:=f591da9ab90ef3d6b3d173766d0ddff90c4ed7330680897486117df390d83c8f | ||
PKG_HASH:=b28daf4ac17e43156363078bf510297584137f6df50fced9b12df34f61a92fb0 | ||
PKG_MAINTAINER:=Thomas Richard <[email protected]> | ||
|
||
UBOOT_USE_INTREE_DTC:=1 | ||
|
@@ -38,6 +38,9 @@ UBOOT_TARGETS := stm32mp135f-dk | |
|
||
UBOOT_MAKE_FLAGS += DEVICE_TREE=$(DEVICE_TREE) | ||
|
||
UBOOT_CUSTOMIZE_CONFIG := \ | ||
--disable TOOLS_MKEFICAPSULE | ||
|
||
define Build/InstallDev | ||
$(INSTALL_DIR) $(STAGING_DIR_IMAGE) | ||
$(foreach img,$(UBOOT_IMAGE), \ | ||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Oops, something went wrong.