by Morgan Aldridge [email protected]
A simple utility to roll the various software update related utilities in OpenBSD into a single command, a la macOS's (nee Mac OS X's) softwareupdate
, including:
- fw_update(8)
- syspatch(8)
- pkg_add(1)
- pkg_delete(1)
- sysupgrade(8)
- checkrestart (if installed)
One script for base developers providing system binary patches,
One for non-free driver firmware available from the Internet,
Three for third-party binary packages built via ports infrastructure,
One for upgrading to the next major OpenBSD release or snapshot,
One for the system administrator in their dark terminal
On the OpenBSD operating system where software needs an update.
One script to run them all, One script to find them,
One script to download them all, and from the shell install them
On the OpenBSD operating system where software needs an update.
(My apologies for the blasphemous merging of Tolkien's ring verse with OpenBSD's manual pages for the various software updare scripts.)
- List, download, or install pending updates for firmware, system patches, packages, and major releases
- Works on -release, -stable, or -current
- Automatically uses snapshots when running a post-beta/pre-release kernel
- Upon installation:
- Installs additional system patches when
syspatch
has updated itself - Uninstalls any unused package dependencies
- Checks for any running processes that might have had their binaries updated, if
checkrestart
is installed - Prompts to reboot if kernel was updated by
syspatch
- Prompts to install next major release upgrade via
sysupgrade
, if available
- Installs additional system patches when
To check for software updates:
doas swupdate -l
To download, but not install software updates:
doas swupdate -d
To install all software updates, including system patches and firmware:
doas swupdate -i
Released under the MIT license.